Contrat Mondial Relay

Vous devez avoir un contrat auprès de la société Mondial Relay pour pouvoir effectuer des livraisons par leur intermédiaire. Si vous n’avez pas encore souscrit de compte professionnel Mondial Relay, vous pouvez en faire la demande à la société Mondial Relay via leur site : https://www.mondialrelay.fr/

Version de PHP

Le plugin nécessite une version de PHP égale ou supérieure à la version 5.6.0. Il est néanmoins fortement recommandé d’utiliser une version de PHP à jour et supportée (vous pouvez retrouver cette information sur la page suivante : https://www.php.net/supported-versions.php).

Package PHP SOAP

Le protocole SOAP est le protocole utilisé pour communiquer avec le Web Service Mondial Relay. Sans cet élément, il ne peut pas y avoir de liens entre votre site WordPress et le système informatique de Mondial Relay. Il s’agit d’un package PHP standard, mais certains hébergeurs ne l’activent pas par défaut.

Vous pouvez vérifier si cette classe est bien activée sur votre site en allant dans le menu “WooCommerce”, sous-menu “État”, onglet “État du système” et en regardant dans le tableau “Environnement serveur” la ligne nommée “SoapClient”.

Si vous avez un message d’erreur, il faut que vous activiez cette classe SOAP sur votre serveur PHP pour pouvoir utiliser le plugin Mondial Relay pour WordPress.

Version de WordPress

Le plugin est compatible avec WordPress à partir de la version 4.0. Il est fortement recommandé d’utiliser la toute dernière version de WordPress disponible.

Version de WooCommerce

Le plugin est compatible avec WooCommerce à partir de la version 3.1. Il est fortement recommandé d’utiliser la toute dernière version de WooCommerce disponible.

Version de Jquery

Le plugin est compatible avec le Jquery inclus nativement dans WordPress (version 1.12.4). Il est également compatible avec jQuery 1.6.+ et 2.+. La compatibilité avec les versions de Jquery 3+ n’est par contre pas assurée.